Cisco Tips & Tricks

May 19, 2006

Cisco Tips from the Master

Filed under: Router — ciscotips @ 9:39 pm

Here is the link to download cisco tips pdf document from the master.

-Sikandar

Advertisements

May 18, 2006

OSPF shortcut

Filed under: IP Routing, ospf — ciscotips @ 5:58 pm

Many of the newbies get confused while configuring OSPF network statements. Wild card masks are sometimes a pain. Although I have already covered wild card masks usage in my earlier post. Here is an example in lieu to OSPF.

OSPF usage

router ospf process id
network x.x.x.x wildcardmask area area-id
Example:-

interface serial0
ip address 172.30.105.86 255.255.255.252

To add serial0 in OSPF, command will be

router ospf 100 —-> 100 is a process id
network 172.30.105.84 0.0.0.3 area 0

Here we have used wild card mask. but you know we can accomplish the same task with following:-

router ospf 100
network 172.30.105.86 0.0.0.0 area 0

Here we are directly advertising interface address rather then network. This is a convenient method as you don't have to always worry abt wild card masks.

May 15, 2006

Preferring OSPF over EIGRP routes

Filed under: IP Routing, ospf — ciscotips @ 8:15 pm

When we have two different routing protocols running, there is always a confusion in route preference. Lets say if we have both EIGRP and OSPF running in our backbone, routes learned from EIGRP will be preferred because OSPF has a default administrative distance of 110 and EIGRP has a default administrative distance of 90 for internal routes.

If the same route prefixes are learned under both routing protocols, EIGRP-learned routes will be installed into the IP routing table because of the lower administrative distance (90 is less than 110). The key to having OSPF routes installed in the Routing Information Base (RIB), instead of EIGRP routes, is to make the administrative distance of OSPF less than that of EIGRP using the distance command.

Usage as per Cisco command refference:-

distance ospf

To define OSPF route administrative distances based on route type, use the distance ospf command in router configuration mode. To restore the default value, use the no form of this command.

distance ospf {[intra-area dist1] [inter-area dist2] [external dist3]}

no distance ospf

Syntax Description
intra-area dist1
(Optional) Sets the distance for all routes within an area. The default value is 110.

inter-area dist2
(Optional) Sets the distance for all routes from one area to another area. The default value is 110.

external dist3
(Optional) Sets the distance for routes from other routing domains, learned by redistribution. The default value is 110.

Defaults
dist1: 110

dist2: 110

dist3: 110

Command Modes
Router configuration

Usage Guidelines
You must specify at least one of the keyword-argument pairs.

This command performs the same function as the distance command used with an access list. However, the distance ospf command allows you to set a distance for an entire group of routes, rather than a specific route that passes an access list.

A common reason to use the distance ospf command is when you have multiple OSPF processes with mutual redistribution, and you want to prefer internal routes from one over external routes from the other.

Examples
The following example changes the external distance to 200, making the route less reliable:

Router A Configuration

router ospf 1

redistribute ospf 2 subnet

distance ospf external 200

!

router ospf 2

redistribute ospf 1 subnet

distance ospf external 200

Router B Configuration

router ospf 1
redistribute ospf 2 subnet

distance ospf external 200
!
router ospf 2

redistribute ospf 1 subnet

distance ospf external 200

May 14, 2006

Preventing Jam Processes

Filed under: Router, Technology and Software — ciscotips @ 9:51 am

We have always seen that there are some processes still sitting in the process memory and doing nothing. It is possible, however, for a process to become jammed, thus monopolizing the CPU. This may not be immediately apparent on some high-end routers (e.g. 7500 with VIPs, GSR12K), it will cause misery eventually, and certainly on the shared memory routers. Sometimes it leads to a router slow down and in some worst cases we are not able to telnet the router.

We can use following commands to prevent processes from jamming the CPU.

1) scheduler process-watchdog hang :-

This command will place the hung processes in the memory but will not schedule it for processing (CPU).

2) scheduler process-watchdog reload:-

This is “not recommended” option, as this will reload the router. But keep in mind in case router is already in unstable state it’s always better to Reload the router.3)

3)scheduler process-watchdog terminate:-

This will terminate the processes in continued operation of the router. It can also lead to a termination of some key processes which can lead to some adverse affects.

Conclusion: – These are pretty helpful commands for terminating dead processes but my suggestion out here is that use these commands will full caution.

May 12, 2006

Route Summarization

Filed under: Technology and Software — ciscotips @ 9:04 pm

When you summarize routes in RIP, IGRP, EIGRP, or OSPF, you're replacing a series of routes with a summary route and mask. With RIP, IGRP, and EIGRP, this actually lessens the size of the routing update packet itself – multiple routes are replaced with the summary route. For instance, the routes 8.0.0.0/8, 9.0.0.0/8, 10.0.0.0/8, and 11.0.0.0/8 can be summarized as 8.0.0.0 252.0.0.0. Only the summary address will be found in the update packet, making it concise yet complete.

Summarizing routes can also make the routing table smaller, yet still allow for complete IP connectivity when done correctly. Using the above example, the four more-specific routes will be replaced by a single summary route. Since the entire routing table is parsed before the routing process is complete, keeping the routing table as small as possible does help speed the routing process as a whole.

Here are some additional tips on route summarization.

With RIP version 2 and EIGRP, manual route summarization is configured on the interface that will be advertising the summary. This is done with the route summarization command "ip summary-address."

RIP version 2 and EIGRP also both perform autosummarization on routes that are advertised across classful network boundaries. This is disabled with the protocol-level command "no auto-summary".

OSPF offers two different route summarization commands. To summarize routes from one OSPF area to another, use the "area range" command to summarize routes learned via redistribution, use the "summary-address" command on the ASBR.

May 11, 2006

passive-interface

Filed under: IP Routing — ciscotips @ 11:32 am

In large enterprise network supporting distribution routers with multiple interfaces, it’s always a tough task to keep track of adjacencies. There are times where you really wonder whether you want to form adjacencies with all interfaces or not.

The solution to this problem has been to configure the routing protocol on all interfaces and manually set the passive-interface command on the interfaces where adjacency was not desired. In some networks, this meant coding 200 or more passive interface statements. With the Default Passive Interface feature, this problem is solved by allowing all interfaces to be set as passive by default using a single passive-interface default command, then configuring individual interfaces where adjacencies are desired using the no passive-interface command

Configuration Example:-

Command

Purpose

Router(config)# router protocol

Configures the routing protocol on the network.

Router(config-router)# passive-interface default

Sets all interfaces as passive by default.

Router(config-router)# no passive-interface 
interface-type

Activates only those interfaces that need to have adjacencies set.

Router(config-router)# network network-address 
[options]

Specifies the list of networks for the routing process..

This feature was introduced with Cisco IOS v12.0. It works for all routing protocols that support the passive-interface command

May 9, 2006

OSPF Cost

Filed under: IP Routing, ospf — ciscotips @ 9:38 pm

CISCO uses the formula 108/Bandwidth (of an interface) to calculate the interface cost. This produces the following costs for the interfaces :

Interface Type Bandwidth Cost

T3

45,045,00 2
Ethernet 10,000,000 10
Fast Ethernet 100,000,000 1

This formula is usable for interface speeds up to 100Mb, but with the introduction of high speed SONET and ATM interfaces in the network, this approach is not adequate. The following example will illustrate the problem.

Using a OC-3 interface, the bandwidth for this interface is 155,000,000. Using the formula 108/155,000,000 = 0.645. OSPF will round all decimals to 1, making it equal to the cost of a fast Ethernet interface. The same would hold true for OC-12, OC-48, and Gigabit Ethernet interfaces. Obviously, this would cause routing problems within the network. having interfaces with different bandwidths having the same cost.

CISCO provides a solution within certain router IOS software to be able to control how OSPF calculates the default metrics for an interface. This feature is enabled under the router ospf process using the ospf auto-cost reference-bandwidth ref-bw. Where ref-bw is the rate in megabits per second (bandwidth). The range is 1 to 4294967; the default is 100. The formula is now changed to be Reference-bandwidth/interface bandwidth. This feature allows us to globally change how the costs are determined by interface speed. This command was introduced in CISCO IOS release 11.2.

Conclusion:- If you are using OC-3 and higher links, you should enable ospf auto-cost reference-bandwidth under your router ospf process. Depending on your organizations routing policies you can implement different methods. The best practice here is specifying ip ospf cost manually for every interface. This is a best method to avoid confusion in route selection.

Console log messages on telnet

Filed under: Router — ciscotips @ 12:44 am

The common problem which Cisco newbie’s face is that how to see debug console messages on telnet prompt. I have been asked this question for multiple times, not only from my juniors but also sometimes from my peers.

Command is “terminal monitor”. By enabling this command, all your console messages can be seen on a telnet session. But a word of caution here, if ever you enable terminal monitor, never forget to turn it off. Otherwise every time you will telnet that router/switch, you will see console messages coming on your telnet screen and sometimes these are quiet annoying.

May 8, 2006

Encapsulation

Filed under: Router — ciscotips @ 10:00 pm

A common problem which I have seen during point to point circuit testing is an Encapsulation problem. If you work in an organization where you don’t have a control on the other side then you know what I am talking about.

I have seen that if you are backbone guy and you are setting your router interface to encapsulation ppp. You will somehow tend to assume that engineer on the other side is also using ppp encapsulation. In most of the cases this assumption always leads to wastage of time in circuit testing.

By default on all cisco interfaces, encapsulation is HDLC ( cisco proprietary) . During testing of new point to point links, always try to verify encapsulation at both ends, if on one side you have hdlc and on other side you have ppp, then your link will never come up.

If you don’t have a control on the other side of the link then either try to configure encapsulation ppp at your side or if you have already configured ppp on your side, try removing it.

Router1(config)# interface serial 0
Router1(config-if)#encapsulation ppp

or

Router1(config)#interface serial 0
Router1(config-if) no encapsulation ppp

Changing encapsulation always work.

Reload Command

Filed under: Router — ciscotips @ 9:31 pm

Last night I was doing an IOS upgrade remotely for one of our remote office. After upgrade I had to apply some ACL’s for QOS. As soon as I applied the ACL I lost the connection. And I was not able to log in to the router after that.

Guess what, I was able to access the router after 10 minutes. How is this possible?

I think some of you must have already guessed it! J. Yeah! Whenever I do any configuration changes remotely, I always issue reload in 15 command. This will reload the router after 15 minutes. But a warning here, If your configuration is successful, try to save your configuration before 15 minutes. Otherwise you will loose your successful configuration also.

Conclusion:-Every time you try to do remote configuration changes, you should try to use reload in x (where x is minutes) command at the start. It will reload your router after x minutes in case you loose your remote telnet connection. If you make a mistake and can no longer get to the router because of the change you made, you have to make the embarrassing call to someone to go “hit the power.” The power cycle takes the router back to the original starting configuration because your change was never saved. Using this command can save you from making embarrassing call.

« Newer PostsOlder Posts »

Blog at WordPress.com.