Cisco Tips & Tricks

June 26, 2006

Configuring a Cisco router as a terminal server

Filed under: Router — ciscotips @ 2:34 pm

when you have a home lab you want to have console connectivity to all your routers at the same time. By using a terminal server (2509-2512 router range) we can accomplish this.

To use a terminal server we need a 2509/2510 8 lines or 2511/2512 16 lines router and 1 or 2 octal cables.
The first thing we do is create a loopback interface that will be used for the reverse telnet sessions from the other devices.
Router(config)#interface loopback0
Router(config-if)#ip address 172.16.1.1 255.255.255.255

Now we add the devices that are connected to this router [octable cable to each console port]
Router(config)#ip host hostname 2001 172.16.1.1
Router(config)#ip host hostname2 2002 172.16.1.1

The previous commands lets you use the hostname of the device to access it on it's console port. The portnumber is made of the following 200x where x is the nr on the octal cable going to that device. Depending on the type of router you use for terminal server you can have either 8 or 16 devices hanging of it.

Now that the router is configured we use the following commands to navigate.
– to access a device
telnet 172.16.1.1 2001

- to switch between active sessions
ctrl-shift-6-x will bring you back to terminal server
show sessions will display the active sessions
entering a number of a session will let you access that session

- to disconnect a session
use the disconnect command

About these ads

49 Comments »

  1. line vty 0 4
    1)exec-timeout 5 0
    2)logout-warning 60
    3)absolute-timeout 15

    1) telnet session will be disconected after 5 min of inactivity)
    2)60 sec before automatically logging off router will send warning message to user to save config
    3)after 15 min router wil disconnect telnet session

    Comment by Roy — July 6, 2006 @ 8:22 pm

    • Do a “show line” and make sure you have the above statements applied to those lines. Depending on the version of code you are running, you should be able to do a “sh run | begin line c” to see those lines quickly. Good luck and if you still have issues, please post a screenshot of the “show line” output.

      Comment by Dan — November 4, 2011 @ 1:19 pm

  2. hi.. can it be done if i would to user cat 4 + 4 to 5 routers to provide this kinda of terminal service function?

    thanks
    charles lim

    Comment by charles — October 12, 2006 @ 10:08 am

  3. charles … could you please explain your problem in more details … i am not able to understand your query.

    Comment by sikandar — October 12, 2006 @ 10:43 pm

  4. Apologize first for a newbie question. Going into a new tech branch after I have been in SQL land for the last 11 years.

    Just starting on my route through network land and learning the cisco routers. I do have a 2511 and trying to configure it for a terminal server. The question I have is, what do you perform if later on you want to either delete an entry or update an entry.

    Thanks,

    d.

    Comment by darrenprog — October 13, 2006 @ 7:09 am

  5. please see the following URL from Cisco..

    Comment by Smiddog — November 7, 2006 @ 3:58 am

  6. Hi. I make this conf on 2600 XM

    interface Loopback0
    ip address 172.16.200.200 255.255.255.255
    !
    interface FastEthernet0/0
    ip address 10.10.0.100 255.255.255.0
    duplex auto
    speed auto
    !

    line 33 48
    session-timeout 60
    no flush-at-activation
    absolute-timeout 60
    transport preferred telnet
    transport input all
    stopbits 1
    flowcontrol hardware

    I suggest run show lines to see what are the port nums on the Async module and octal cable

    Comment by NEO — November 30, 2006 @ 1:45 am

  7. Hi,
    I want to create a logon session so that users can register and logon like the commercial rack rentals. Are there any software around?

    Cheers,
    Tony

    Comment by Tony — December 12, 2006 @ 1:21 am

  8. My terminal server has 7 routers and switches attached to it via octal cables. the C3745 router for some reason prompts me for a username and password for tty lines that are not in use.
    For example I installed a new router to tty 39 (syntax 2039) when I telnet to the router via the terminal server (10.10.98.20) —> 10.10.98.20 2039 it prompts me for a username and password. But after I type the correct username and password, I am unable to connect.
    The same goes for all the other tty line 2040 – 2064. For all these I get prompted for a username and password even thought nothing is connected.

    Comment by Joey — January 22, 2007 @ 6:31 pm

  9. How do you configure the host routers so that they can communicate with the terminal server?

    Comment by sam tabaziba — March 1, 2007 @ 8:02 pm

  10. I set up a terminal server using 2500 and I used an octal cable to connect to 4 2600 routers. When I telnet to a router I am not able to type anything else. I used the debug telnet and the TCP connection is open. Do I have to configure the terminal type in the attached router ( I mean the 2600). My used the configuration from Bryant Advantage website.

    Comment by francoise aurtenechea — April 20, 2007 @ 10:39 pm

  11. That means that you are not getting the login prompt. Make sure that telnet is allowed with the command “transport input telnet” ,Or you can use the “transport input all” command

    If still you have problem, use the “debug telnet” command to see what is going wrong.

    Comment by Jo — June 17, 2007 @ 6:58 am

  12. What are the disadvantages of using a 2512 in a home lab for CCNP compared to a 2509 or 2511. The 2512 has a Token Ring port instead of an Ethernet or AUI but does it matter if you are using the device as an access server? My other routers are 2501-2503-2514-2520 plus a 2912 switch

    Comment by John — June 26, 2007 @ 8:33 am

  13. How do i config frame-relay switching on a cisco router 2522, with three cisco 1845 router in a hub and spoke config.

    Comment by Reagan — July 30, 2007 @ 3:07 am

    • Google Chris Bryant Frame Relay Switch

      he has the exact config you need

      Its not hard, ive adapted that to build a full frame CCIE lab

      Comment by nick C — May 4, 2011 @ 1:15 pm

  14. Reagan,
    I am trying to configure cisco 26020 with an NM-4A/S port to my other devices the common denominator is db60 ports found on my other devices 1700, 2611, etc. I am trying to enable the ports, then issue the command interface async port/slot as shown in the cisco documentation. It actually say “5-5″ but Everything I have tried just don’t work. Any suggestions? My 1700 has 2- WIC-1T ports, and the 2611 also has an NM-4A/S module. All are connected to 2511, and a 2509 terminal server. Any thoughts would be greatly appreciated.

    jc

    Comment by Jesse — August 25, 2007 @ 4:36 am

  15. In my lab 2509, which is relatively small and which I manage on my LAN, my setup is quite simple:

    version 11.3
    no service password-encryption
    !
    hostname 2509-ts
    !
    enable secret 5 $1$FJw4$wnl7PsB.0kRuklKLNzd3I/
    !
    username admin
    !
    !
    interface Loopback0
    no ip address
    !
    interface Ethernet0
    ip address 192.168.16.253 255.255.255.0
    bandwidth 10000000
    !
    interface Serial0
    no ip address
    no ip mroute-cache
    shutdown
    no fair-queue
    !
    interface Serial1
    no ip address
    shutdown
    !
    interface Async1
    no ip address
    !
    ip default-gateway 192.168.16.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.16.1
    !
    line con 0
    no exec
    exec-timeout 35791 0
    telnet break-on-ip
    telnet sync-on-break
    telnet ip-on-break
    flowcontrol hardware
    line 1 8
    session-timeout 35791
    exec-timeout 35791 0
    password admin
    login local
    transport input all
    stopbits 1
    line aux 0
    line vty 0 4
    no login
    !
    end

    No additional IP HOST HOSTNAME commands were needed. Just go thru the Ethernet port and specify the line number as the port number in the Telnet app. Works like a champ.

    Comment by rgrace — November 6, 2007 @ 6:27 pm

    • Great example on showing how to configure a 2509 as a Terminal Server.

      Since I am new at this, I kinda got stuck at your last comment and would appreciate if you could further clarify.

      “Just go thru the Ethernet port and specify the line number as the port number in the Telnet app”

      My AS2509RJ is configured as above. So what are my next steps?

      Thx Mic

      Comment by mic — July 24, 2009 @ 4:25 am

  16. i cant configure my router

    Comment by aziz — November 29, 2007 @ 10:39 am

  17. Aziz! You rock dude!

    Comment by xfiles — January 31, 2008 @ 6:24 pm

  18. i configuer access router 2511 but i can telnet only 5 devices at a time and i have 16 devices conneted to access router how would i able to telnet 16 devieces at a time

    Comment by numan — April 8, 2008 @ 6:42 am

  19. Numan,
    You need to create more vty – by default there is only 5 on a router.

    line vty 5 15
    password

    Comment by nic — August 11, 2008 @ 11:23 am

  20. Nic,

    I have a similar problem as Numan. How do you create more vty lines?

    Thanks

    Comment by Daniel — November 23, 2008 @ 6:46 pm

    • You need the terminal server version of IOS – you can then create something like 99 vty sessions. Otherwise you are stuck with just 5 on 2500’s.

      Cheers,
      Simon

      Comment by Simon — July 19, 2010 @ 4:23 pm

  21. Hi Guys,
    I am using a terminal server 2610 to access few devices. All was working fine until I decided to put ACS on the terminal Server.

    From then onwards, I am not able to log on to my devices connected to the terminal server.

    That gives me the timeout error response and close the session.

    Any thoughts?

    Comment by Saad — April 22, 2009 @ 11:46 am

  22. Dear all, thanks!

    I’ve managed to configure my 2511 into console server from instructions on this website.

    Comment by Affan — August 22, 2009 @ 5:27 am

  23. Can i use ssh to connect the console server then telnet?? or only telnet and how to config it??? i cant! because ssh use 22 port, and i try to connect for example on 2008 port like router>telnet 192.168.1.1 2008

    Comment by Dmitryi — March 2, 2010 @ 5:15 pm

    • i dont think 2511 supports ssh.

      hence, you need to upgrade to a new platform.

      then ssh into, say, 3725. from there, you telnet into the 2511.

      Comment by cp — April 10, 2010 @ 9:03 pm

  24. Hi, my name is Jean-Francois and I’m an IP specialist in my firm.
    I have set a terminal server (cisco 2811) to my Service Provider network.
    My core network is made of cisco 7600’s and juniper t640, m320 and m10i.
    2 things:
    I can successfully perform reverse telnet on my cisco devices but not the junipers. the second is that when performing the reverse telnet to my cisco equipments, my banners are coming up and then prompts me for username and pasword. When I use my TACACS, not working (could be an access-list blocking this operation). I’ve managed to obtain the correct username and password, but next it is prompting me for secret password that I don’t know. I thought about reconfiguring the secret to be something that I know, but can’t just proceed because of politics between IP planning and IP operations.

    Comment by Jean-Francois — September 17, 2010 @ 12:48 pm

  25. Anybody out there ever use a terminal server router to gain console access on a Cisco 3110 switch module? Any tricks to getting that working since it is a USB console port?

    Comment by Dan Petrucci — September 28, 2010 @ 7:06 pm

  26. [...] Configuring a Cisco router as a terminal server June 2006 29 comments 4 [...]

    Pingback by 2010 in review « Cisco Tips & Tricks — January 2, 2011 @ 6:55 am

  27. Hi, I wonder if they know how to configure a Cisco Access Server 3640 as I set the following:

    192.168.2.1 ip host R4 3097
    !
    !
    !
    !
    Loopback1 interface
    For description Lan Virtual Console
    ip address 192.168.2.1 255.255.255.0
    direct-broadcast no ip

    line with 0
    password 7 0806434013180918
    login
    transport input none
    97 112 line
    no exec
    exec-timeout 0 0
    transport input all
    line aux 0
    line vty 0 4
    7 00231C081E5A0709 password
    login
    !
    end

    the error that comes is:

    FR_SW_ACCESS_SERVER # R4
    Trying R4 (192.168.2.1, 3097) …
    % Connection refused by remote host

    can you help?

    Thanks & Regards

    Comment by Gonzalo Aguilera — January 25, 2011 @ 11:38 pm

  28. I have a unique issue.

    I have configured 2621 as access router and I am able to switch to any other router.
    The problem is this;

    I can not get back to access terminal with ‘ctrl-shift-6-x. yes I am stuck at the router i got to.

    help me please ..

    Comment by Syed — May 28, 2011 @ 8:35 am

  29. you can find more cisco router or cisco switch information at http://www.router-switch.com

    Comment by routerswitch — July 1, 2011 @ 6:56 am

  30. We have a 2620 Terminal Server with two octo-cables connected to the first 16 ports of a 32-port Async card. All 16 lines are connected to Console ports of Cisco routers and switches, but only seven are working where the LEDs on the back of the TS are lit and connections can be made to the equipment. I have checked the configs for both working and non-working equipment consoles and they are identical for the console port. I have successfully connected and logged in to *all* of the equipment’s console ports using a laptop and TeraTerm app. If I connect a working line to a non-working console port the LED goes dark and I can not connect. If I connect a non-working line to a working console port, it’s LED lights up and I can connect. This would seem to indicate that the problem is with the equipment I am attempting to connect to and not with the TS, it’s cables or config. I have found nothing in Cisco documentation or around the Internet discussion groups that address this type of problem.

    Comment by Bob D'Amore — August 3, 2011 @ 11:56 am

    • Got a solution from someone who looked over my config file:
      !
      line con 0
      exec-timeout 30 0
      password
      logging synchronous
      login
      line 33 64
      exec-timeout 30 0
      logging synchronous
      modem Host <<==== had to remove this config command
      transport input all
      line aux 0
      no exec
      transport input all
      line vty 0 4
      exec-timeout 30 0
      password
      logging synchronous
      login
      line vty 5 45
      login
      !

      I can now connect to console ports using all 16 available lines except for whatever reason the LEDs still won’t lite up on the back of the TermServer for 9 of the 16 ports. I can live with that. Two Cisco boxes return “% Connection refused by remote host”. The configs for these two boxes look the same as the ones that connect so I don’t know what the deal is. If anyone has any suggestions what could cause the console connection to be rejected, please let me know.

      Comment by Bob D'Amore — August 3, 2011 @ 8:20 pm

      • I just config’d a 2600XM series and I noticed the the ports that my switches are connected too will not light. I move the connections around and they dont light in any of the 36 ports but the routers will make them light.

        I do have an issue that I can’t figure out, once I log into all the devices I can’t go back. I can only go back to the access server or to the last device I connected to.

        Comment by Kevin — January 23, 2012 @ 12:39 pm

  31. Hi,

    I would really appreciate if anyone could help me out with this issue.

    I am working on Cisco AS2511-RJ Terminal Server. It has 16 ports.

    My goal is to be able to Telnet the nodes(routers) connected to the ports of this AS2511-RJ Terminal Server.

    I am facing this peculiar situation.

    I connected a working router to one of the port i.e. port #2009 of the terminal server.
    I telnet using IP address of the terminal server and port number 2009.
    I am able to connect to the node.

    However,when I connect this node to few other ports,I see that I am unable to telnet to the connected node.

    I get a notification saying ‘Password OK’ but no further response.

    I have verified this node with a working port and it responds.

    Hence,I need advise as to why some ports of the terminal server do not respond.

    Is this an indication that the port is faulty? What other approaches could I incorporate in order to get these ports working?

    Thanks and appreciate your help!!

    Comment by Abhijit K — November 3, 2011 @ 9:51 pm

    • Continuing with my post above, I also tried changing the settings to the initial default(i.e. factory settings). Still I have only four of the ports responding to a connected node.

      The nodes are all working but the ports just do not respond despite all above mentioned approaches? Does this suggest the terminal server ports are bad?

      Comment by Abhijit K — November 8, 2011 @ 11:39 pm

  32. i bought a cisco terminal server 2511 from ebay and cant break the password on it. what should i do?
    i have use crt + break but is not working.

    Comment by abraham siaw — March 4, 2012 @ 12:37 am

  33. crt + break should work with either HyperTerm or Putty. Just make sure you hit it within 5 seconds of when you boot that router.

    Comment by Dan — March 4, 2012 @ 7:34 am

  34. TS(config)#LINE ?
    First Line number
    aux Auxiliary line
    console Primary terminal line
    tty Terminal controller
    vty Virtual terminal
    x/y Slot/Port for Modems
    WHAT DO I HAVE TO CHOOSE TO CREATE A TS

    Comment by networksolution.mann@gmail.com — January 17, 2013 @ 8:13 am

  35. i have a router c2600 with ASYNC 16A HOW I HAD TO CONFIGURE IT TO USE IT AS A TERMINAL SERVER
    PLZ RPLY AS FAST U CAN

    Comment by networksolution.mann@gmail.com — January 17, 2013 @ 8:14 am

  36. HI,
    need some help here please.

    I am using a cisco 3640 with NM16A as my Access Server..I have configured as below but not sure why it is not working
    !
    !
    ip cef
    ip host R1 2001 100.1.1.1
    ip host R2 2002 100.1.1.1

    !
    !
    interface Loopback0
    ip address 100.1.1.1 255.255.255.255

    AccessServer3640#sh line
    Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns Int
    * 0 CTY – – – – – 0 0 0/0 –
    * 65 TTY 9600/9600 – – – – – 0 2 14/44 – <<<plugged in to R1
    66 TTY 9600/9600 – – – – – 0 0 0/0 – <<<Plugged out from R2
    67 TTY 9600/9600 – – – – – 0 0 0/0 –
    68 TTY 9600/9600 – – – – – 0 0 0/0 –
    69 TTY 9600/9600 – – – – – 0 0 0/0 –

    just trying to make one line (65) work first..

    line 65 80
    no flush-at-activation
    transport input all
    transport output all
    stopbits 1
    flowcontrol hardware
    line aux 0

    Please help..been hours tryna figure it out :(

    thanks,
    Bear

    Comment by Bear — May 12, 2013 @ 11:02 am

  37. You can find more cisco router or cisco switch information at http://www.3anetwork.com

    Comment by samchen — September 3, 2013 @ 6:48 am

  38. Awesome post. really your post is helpful for every user. i am loving it.
    Cisco ip phone

    Comment by jmanuel — September 18, 2013 @ 12:31 pm

  39. I need some help. Not sure what is wrong.

    Error:

    CommServer#telnet 172.21.1.1 2001
    Trying 172.21.1.1, 2001 …
    % Connection refused by remote host

    CommServer#sh line
    Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns
    * 0 CTY – – – – – 0 0 0/0
    1 TTY 9600/9600 – – – – – 0 0 0/0
    2 TTY 9600/9600 – – – – – 0 0 0/0
    3 TTY 9600/9600 – – – – – 0 0 0/0
    4 TTY 9600/9600 – – – – – 0 0 0/0
    5 TTY 9600/9600 – – – – – 0 0 0/0
    6 TTY 9600/9600 – – – – – 0 0 0/0
    7 TTY 9600/9600 – – – – – 0 0 0/0
    8 TTY 9600/9600 – – – – – 0 0 0/0
    9 TTY 9600/9600 – – – – – 0 0 0/0
    10 TTY 9600/9600 – – – – – 0 0 0/0
    11 TTY 9600/9600 – – – – – 0 0 0/0
    12 TTY 9600/9600 – – – – – 0 0 0/0
    13 TTY 9600/9600 – – – – – 0 0 0/0
    14 TTY 9600/9600 – – – – – 0 0 0/0
    15 TTY 9600/9600 – – – – – 0 0 0/0
    16 TTY 9600/9600 – – – – – 0 0 0/0
    17 AUX 38400/38400 – – – – – 0 0 0/0
    18 VTY – – – – – 0 0 0/0
    19 VTY – – – – – 0 0 0/0
    20 VTY – – – – – 0 0 0/0
    21 VTY – – – – – 0 0 0/0
    Tty Typ Tx/Rx A Modem Roty AccO AccI Uses Noise Overruns

    22 VTY – – – – – 0 0 0/0

    CommServer#sh sessions
    % No connections open

    CommServer#sh run
    Building configuration…

    Current configuration:
    !
    version 11.2
    no service password-encryption
    no service udp-small-servers
    no service tcp-small-servers
    !
    hostname CommServer
    !
    !
    ip subnet-zero
    ip domain-list cisco.com
    no ip domain-lookup
    ip host r1 2009 172.21.1.1
    ip host 2800-1 2001 172.21.1.1
    ip host 2800-2 2002 172.21.1.1
    ip host 2800-3 2003 172.21.1.1
    ip host 2800-4 2004 172.21.1.1
    ip host 2800-5 2005 172.21.1.1
    ip host 2800-6 2006 172.21.1.1
    ip host 2800-7 2007 172.21.1.1
    ip host 2800-8 2008 172.21.1.1
    ip host 2800-9 2009 172.21.1.1
    ip host 2800-10 2010 172.21.1.1
    ip host 2800-11 2011 172.21.1.1
    ip host 2800-12 2012 172.21.1.1
    ip host 2800-13 2013 172.21.1.1
    ip host 2800-14 2014 172.21.1.1
    ip host 2800-15 2015 172.21.1.1
    ip host 2800-16 2016 172.21.1.1
    !
    interface Loopback1
    ip address 172.21.1.1 255.0.0.0
    no ip directed-broadcast
    !
    interface Ethernet0
    no ip address
    no ip directed-broadcast
    no ip mroute-cache
    shutdown
    !
    interface Serial0
    no ip address
    no ip directed-broadcast
    no ip mroute-cache
    shutdown
    !
    interface Serial1
    no ip address
    shutdown
    !
    ip default-gateway 192.168.1.1
    ip classless
    ip route 0.0.0.0 0.0.0.0 192.168.1.1
    !
    line con 0
    line 1 16
    session-timeout 20
    no exec
    exec-timeout 0 0
    line aux 0
    transport preferred telnet
    transport input all
    rxspeed 38400
    txspeed 38400
    flowcontrol hardware
    line vty 0 4
    exec-timeout 60 0
    password ccnp
    login
    !
    end

    Comment by Paul — October 10, 2013 @ 7:00 pm


RSS feed for comments on this post. TrackBack URI

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

The Silver is the New Black Theme. Create a free website or blog at WordPress.com.

Follow

Get every new post delivered to your Inbox.

Join 43 other followers

%d bloggers like this: